Установка двух серверов 1С на Windows
Рассмотрим для чего нам может понадобиться установить второй сервер 1С и как это сделать на ОC Windows.
Для чего нужен второй экземпляр сервера 1С
Основными причинами, по которым необходим запуск двух служб сервера 1С на одной машине это:
1. Создание тестового контура 1С. По понятным причинам, разработка и отладка программ 1С на продуктивном сервере плохая идея. В лучшем случае это будет замедлять производительность рабочего контура 1С, в худшем приведет к его падению и простою. Чем это чревато, думаю не стоит говорить.
2. Необходимость запуска серверов 1С разных версий. Данный вариант так же довольно часто становиться актуальным если используется большое количество конфигураций. Для работы некоторых конфигураций иногда требует более свежая версия платформы. Но часто по разным причинам новые релизы платформы не отличается стабильностью и переносить все продуктивные базы на них не очень хорошее решение.
3. Наконец работа нескольких служб сервера 1С на одной машине позволяет в ручном режиме дифференцировано настроить производительность кластера 1С для отдельных баз данных.
Установка второго сервера 1С одной версии
Итак, будем считать, что у нас на компьютере уже установлен один экземпляр сервера 1С. Чтобы запустить второй экземпляр сервера 1С установленной версии необходимо:
1. Запускаем утилиту «Командная строка» от имени администратора:
2. Выполним в командной строке следующую команду, создадим службу 1CServer_test:
|
1 |
sc create 1CServer_test binPath= "C:\Program Files (x86)\1cv8\8.3.17.1549\bin\ragent.exe" |
После выполнения, должны увидеть CreateService: успех

3. Заходим в редактор реестра. Находим там в ветке HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ services нашу службу 1CServer_test:
4. Меняем ключ ImagePath, вносим туда такую строку:
|
1 |
"C:\Program Files\1cv8\8.3.17.1549\bin\ragent.exe" -srvc -agent -regport 1641 -port 1640 -range 1660:1691 -d "C:\Program Files\1cv8\srvinfo_16" |
Здесь мы изменили типовые порты, который уже заняты первым экземпляром сервера. Вместо указанных в примере можно задать свои значения. При необходимости можно прописать ключ -debug чтобы включить отладку на сервере 1С. Подробней про отладку можно почитать тут.
Установка второго сервера 1С другой версии
Если вы хотите запустит второй экземпляр сервера 1С другой версии, то необходимо в ключ ImagePath прописать строку запуска исполняемого файла агента сервера из каталога другого релиза. Например если мы хотим запустить сервер релиза 8.3.15.1830, то вносим такую строку:
|
1 |
"C:\Program Files\1cv8\8.3.15.1830\bin\ragent.exe" -srvc -agent -regport 1641 -port 1640 -range 1660:1691 -d "C:\Program Files\1cv8\srvinfo_16" |
Запуск второго экземпляра сервера 1С
1. Заходим в раздел «Службы», ищем созданную нами службу 1CServer_test и задаем если надо необходимые настройки. Можно, например, задать пользователя, под которым будет работать второй экземпляр сервера 1С:
2. После сохранения настроек службы стартуем ее. Контролируем что состояние службы стало «Работает».

3. Переходим к проверке работы второго экземпляра сервера 1С. Создаем через консоль серверов 1С подключение к нашему новому серверу. Указываем тот порт, агента сервера, который мы задали в настройках службы, в данном случае 1640: 
4. Создаем подключение к базе расположенной на втором экземпляре сервера 1С. Напомню, что обращаться к этому кластеру серверов 1С надо уже с указанием порта менеджера кластера, например, так: SRV1C:1641

Итоги
Как видим запуск второго сервера 1С не представят особого труда и в тоже время дает ряд преимуществ. Так запуск нескольких экземпляров сервера 1С на одной машине позволяет более гибко осуществлять настройку и эксплуатацию как рабочих так и тестовых контуров 1С.
Еще можно посмотреть
Разворачиваем виртуальный сервер VirtualBox для 1С и не только
Рассмотрим как разворачивать виртуальный сервер VirtualBox для установки сервера 1С на Linux
Установка и настройка хранилища конфигураций 1C на Linux сервере
Хранилище конфигурации 1С:Предприятия 8.3 является инструментом групповой разработки. Настраиваем сервер хранилища на Linux.
Установка двух версий сервера 1С на Linux
Пошаговый процесс установки и запуска двух версий сервера 1С на Linux. Полное описание настройки второго экземпляра сервера 1С.
Анализ технологического журнала 1С регулярными выражениями. От простого к сложному.
Что делать, если у пользователя возникают ошибки, «все тормозит» или возникают другие неясные проблемы, а разработчик не знает где искать проблему в коде? С этой статьи мы начинаем нашу рубрику по расследованию проблем производительности и стабильности работы систем на базе 1С:Предприятия. Речь пойдет о реальных примерах анализа технологического журнала 1С экспертами с помощью регулярных выражений. […]
Настройка выделенного сервера лицензий 1С Предприятия
Настраиваем сервер лицензий 1С на выделенном компьютере. Пошаговый процесс настройки.
1C тормозит и возникают ошибки. С чего начать расследование?
Когда мы читаем о том, как настраивать и анализировать технологический журнал 1С на предмет «узких» мест, мы не всегда представляем себе, что это отнюдь не первое, что нужно сделать, когда сталкиваемся с падением производительности и стабильности работы системы. Прежде чем «бросаться» собирать технологический журнал и его парсить, изначально рекомендуется провести первичный сбор информации о проблеме: […]
Ошибки на клиенте при работе с сервером 1С на Linux. Часть 2
Разбор наиболее часто встречающихся ошибок при работе с 1С на Linux.
Похожие записи
- Ошибка 1С:Предприятие «Потеряно соединение»
- Очистка кэша: серверного и клиентского для 1С:Предприятия
- 1C тормозит и возникают ошибки. С чего начать расследование?
- Анализ технологического журнала 1С регулярными выражениями. От простого к сложному.
- Администрирование серверов 1С на Linux
- Настройка и сбор логов для анализа проблем производительности систем 1С на Linux
- Утилита ring license для 1С версии 8.3.14 и выше под Linux
- Разворачиваем виртуальный сервер VirtualBox для 1С и не только
- Ошибка «Слишком много открытых файлов» или«Too many open files» В 1С на Linux
- Ошибки СУБД. 1С+PostgreSQL+Linux. Часть 2.









